Opening and managing files

You can open local FileMaker Pro files (located on your computer). You can also:

  1. To

    Do this

    Open a local file

    Choose File menu > Open. Navigate to the file, then select the filename and click Open.

    Open a favorite file

    • Choose File menu > Favorites > Show Favorites. In the Favorites window, double-click a filename.
    • Choose File menu > Favorites, then choose a filename in the menu.

    See Working with favorite files and hosts.

    Open a file that you recently opened

    • Choose File menu > Recent > Show Recent. In the Recent window, double-click a filename.
    • Choose File menu > Recent, then choose a filename in the menu.

      To display recent files in the Recent menu, see Setting general preferences.

      To remove a file from the Recent window and Recent menu, in the Recent window, right-click the filename and choose Remove. The file isn’t deleted from the hard disk; it is only removed from the lists.

  2. Enter an account name and password if asked.

    See Opening files protected with passwords.

Notes 

  • To open multiple windows for a file, choose Window menu > New Window. This allows you to view the same layout in separate windows, or to simultaneously view different layouts in the same file. You can perform sort operations and find operations independently in the different windows.
  • When you open a file saved with date, time, and number formats that are different from the system formats set on your computer, you might see an alert message. Choose to display and sort data using the file’s formats or the system’s formats. See Opening files with different system formats.
  • If a file opens with a default account name and password, you can specify different account information by pressing the Shift key (Windows) or the Option key (macOS) when opening the file.
  • For information on displaying a specific layout when a file opens, see Setting file options.
  • Even if you close a file, it may remain open as a hidden file if the window of any other file is displaying data from that file. (For example, another window may be displaying related data from the file you attempted to close.) FileMaker Pro will close the file when you close all dependent windows.
  • All versions of FileMaker Pro since version 12 open files in the FMP12 format without needing to convert the files. Files created with earlier versions must be converted. See Converting files from FileMaker Pro 11 and earlier.