外部データソースへの接続

データソースは他の FileMaker Pro ファイルまたは ODBC データベースからのデータにアクセスします。次のデータに接続できます:

  • FileMaker データソース
  • ODBC データソース (外部 ODBC ファイルへのリンク)

一度、データソースを定義すると、ODBC、または FileMaker テーブルからのデータを、ローカルファイルのデータとして、たとえばレイアウト上やスクリプトで使用できます。

追加するデータソースの種類により次の手順に従います。

FileMaker データソースの追加:

  1. データベースが開いている状態で、[ファイル] メニュー > [管理] > [外部データソース...] を選択します。
  2. [新規...] をクリックします。

    [データソースの編集] ダイアログボックスが表示されます。[タイプ:] は、デフォルトで FileMaker が選択されます。

  3. データソースの名前を入力します。

    これは、ログインと他のダイアログボックスに表示される名前です。

  4. [ファイルの追加...] をクリックします。
  5. FileMaker Pro ファイルを選択して、パス一覧に追加します。
  6. [開く] をクリックして、このファイルへのパスをファイルパス一覧に追加します。

    それぞれの名前を付けた FileMaker データソースは、1 つ以上のファイルパスから構成されます。該当すると思われる複数のファイルを検索する場合は、複数のファイルパスを使用します。ファイルパスの作成を参照してください。

    ファイルパス一覧に直接ファイルパスを入力することもできます。各ファイルパスは個別の行に記述する必要があります。

  7. [OK] をクリックしてデータソースを保存します。

    [外部データソースの管理] ダイアログボックスに、作成順に名前の付いたデータソースが表示されます。アルファベット順またはカスタム順で名前の表示を選択することができます。

    [タイプ] では、データソースが FileMaker か、ODBC データベースかを示します。ファイルパスは、[詳細] の下に記載されます。

メモ  または [データベースの管理] ダイアログボックスの [リレーションシップ] を選択して、テーブル追加ボタン をクリックすることができます。[テーブルを指定] ダイアログボックスで、[データソース] > [FileMaker データソースの追加...] を選択します。テーブルオカレンスの追加と選択を参照してください。

FileMaker データソースの編集を参照してください。

ODBC データソースの追加:

重要 SQL データソースを作成する前に、ODBC ドライバを使用して外部データソースに接続して、DSN を設定する必要があります。ODBC クライアントドライバの設定を参照してください。

  1. FileMaker データベースが開いている状態で、[ファイル] メニュー > [管理] > [外部データソース...] を選択します。
  2. [新規...] をクリックします。
  3. [タイプ:] で [ODBC] を選択します。
  4. データソースの名前を入力します。

    名前の長さは、100 文字を超えることはできません。

  5. [DSN:] で、[指定...] をクリックします。
  6. [ODBC データソースを選択] ダイアログボックスで、この FileMaker Pro ファイルから使用して操作する [システム DSN] を選択します。
  7. その他のオプションを設定します。ODBC データソースの編集を参照してください。
  8. [OK] をクリックします。

こうして、[外部データソースの管理] ダイアログボックスにデータソースがリストされます。

メモ  または [データベースの管理] ダイアログボックスの [リレーションシップ] を選択して、テーブル追加ボタン をクリックすることができます。[テーブルを指定] ダイアログボックスで、[データソース:] から [ODBC データソースの追加...] を選択します。テーブルオカレンスの追加と選択を参照してください。

外部データソースの削除:

  1. [外部データソースの管理] ダイアログボックスで、一覧からデータソースを選択します。
  2. [削除] をクリックします。

    これにより、現在の FileMaker Pro ファイルへのデータソースリンクだけを削除します。データソースは、他の FileMaker データベースにまだリンクすることができます。

  3. [OK] をクリックします。