Reference > Setting preferences > Setting general preferences
 

Setting general preferences

General application preferences affect the way you work with all FileMaker Pro documents.

1. Windows: Choose Edit menu > Preferences.

macOS: Choose FileMaker Pro menu > Preferences.

2. Click the General tab.

 

To

Do this

Enable drag and drop capabilities to move text in fields, between fields, and between layouts, as well as between applications that support drag and drop

Select Allow drag and drop text selection.

Display the names of up to 30 recently opened files in the File menu > Recent menu or in the Recent window

Select Show recently opened files, and then enter a number from 1 to 30.

Display the Manage Database dialog box when you create a new file

Select Use Manage Database dialog to create files.

Deselecting this option displays Layout mode. See Defining and changing fields in the Fields tab.

Reset the size and position of all dialog boxes to their defaults

For Reset dialog sizes and positions, click Reset.

Set the name that identifies the user

(This value is used, for example, when you choose Insert menu > Current User Name.)

Windows: Type a name for User name.

macOS: Select System in the User Name area or, for User Name, select Other, and then type a name in the text box. (The system name is the name entered in System Preferences. See macOS Help.)

Set the language that FileMaker Pro uses for menus, dialog boxes, and messages

Windows: For User Interface Language, choose a language.

macOS: Use System Preferences. See macOS Help. (You must log out from macOS and log back in to see the new language.)

Notes

The new language does not take effect until you restart FileMaker Pro. If some language components are not installed, you may be alerted to install a language pack. See FileMaker Pro Installation Guide.

This setting does not change the system formats used for displaying and sorting dates, times, and numbers in a particular file. For more information on system formats, see Opening files with different system formats.

Windows: Set the style of font smoothing

For Font smoothing style, choose a style.

Notes

If the fonts on your screen look fuzzy, you may want to experiment with the different font smoothing styles until you find one that looks best with your monitor.

In Windows, font smoothing is turned off at the 100% zoom level and higher.

In macOS, you can set font smoothing options in System Preferences. See macOS Help.

Use FileMaker Pro development and deployment features, such as Script Debugger, custom menus, and database encryption

Select Use advanced tools.

See Using advanced tools.

Note  You must restart FileMaker Pro after selecting this preference in order to use the advanced tools. You must also restart FileMaker Pro if you deselect the preference to stop using the tools.

Open a file when FileMaker Pro starts, or update the file to open.

Select At startup, open file and browse to the file or enter the file’s path.

See Creating file paths.

Related topics 

Creating a custom app

Keyboard shortcuts (Windows)

Keyboard shortcuts (macOS)

Formatting fields and text for vertical writing