Using advanced tools > Defining custom menus > Creating and editing custom menu sets
 

Creating and editing custom menu sets

Note  This feature is available when the Use advanced tools general preference is selected. See Using advanced tools.

You can create custom menu sets to include the menus you require. You can then specify a menu set for the file and for individual layouts.

Important  Duplicating a custom menu set creates a copy of the menu set and references the same custom menus as the original menu set. It does not duplicate the custom menus. If you change a menu item, you change the menu for all menu sets in which the menu is included.

To create, edit, duplicate, or delete menu sets:

1. Choose File menu > Manage > Custom Menus > Custom Menu Sets tab.

2. Specify settings in the Manage Custom Menus dialog box, then click OK.

If you selected Create or Edit, you see the Edit Menu Set dialog box.

3. Specify which menus you want to include in the menu set.

To duplicate and edit the standard FileMaker Pro menu set:

1. Choose File menu > Manage > Custom Menus > Custom Menus tab.

2. Click Create.

3. In the Create Custom Menu dialog box, click Start with a standard FileMaker menu, select a menu from the list, then click OK.

4. In the Edit Custom Menu dialog box, change Menu Name and modify any other settings, then click OK.

See Defining custom menus.

5. Repeat steps 2 through 4 for each standard FileMaker Pro menu.

6. In the Manage Custom Menus dialog box, click the Custom Menu Sets tab, then click Create.

7. In the Edit Custom Menu Set dialog box, for Menu Set Name, enter a descriptive name (for example, Standard FileMaker Menus Copy), then click Add.

8. In the Select Menu dialog box, select the menus for this menu set, then click Select.

9. In the Edit Custom Menu Set dialog box, drag an arrow Double arrow control up or down to change the order of the menus in the list, then click OK.

10. In the Manage Custom Menus dialog box, click OK.

Specifying options for installing menu sets

After you create menu sets, you must specify options for installing them. You can:

specify a default menu set for a file

specify menu sets for individual layouts (see Specifying a menu set for a layout)

create scripts that change menu sets (see Install Menu Set script step)

specify menus within the menu set to display according to mode (see Defining custom menus)

Notes 

macOS:

If you do not include a Help menu in your menu set, the operating system will install an empty Help menu. You cannot remove this menu, change its position on the menu bar, or change its title.

The FileMaker Pro menu is added after the Apple menu. You cannot customize the Quit or Preferences menu items. You can only customize the About FileMaker Pro menu item.

Windows: The Exit menu item is added at the end of the first unlocked (modifiable) menu. You cannot customize the Exit menu item.

You can Shift-click, or Ctrl-click (Windows) or Command-click (macOS) additional menus to add multiple menus to the menu set.

Each time you switch layouts, FileMaker Pro installs the menu set specified in the Menu Set option in the Layout Setup dialog box.

When you copy a menu set, the menus referenced in the menu set are not copied. The referenced menus must already exist in the file that you paste into.