Adding and viewing data > Checking spelling
 

Checking spelling

FileMaker Pro can check the spelling of text in the following locations:

a selected word or passage in a field

the visible fields in the current record only (including any related fields)

the visible fields in all records in the current found set (including any related fields)

while in Layout mode, all the text objects in the current layout (including any text objects on tab panels or slide panels that are not in front)

You can set FileMaker Pro to check spelling as you type or to indicate possible misspellings with a red dotted underline in text that’s being edited. You set these options on the Spelling tab of the File Options dialog box. See Setting file options.

FileMaker Pro by default checks spelling on a field-by-field basis. To disable spell-checking individual fields, in the Behavior area of the Data Data tab of the Inspector, select Do not apply visual spell-checking.

When you check spelling, FileMaker Pro compares your text against two dictionaries, the main dictionary and the user dictionary. The main dictionary is preset to match your local language (for example, in the United States, usenglsh.mpr). You can’t edit the main dictionary, but you can change it to another language. The main dictionary is always available.

FileMaker Pro includes spelling dictionaries in the following languages: Dutch, French, Italian, German, Portuguese (Brazil), Portuguese (Portugal), Spanish, Swedish, Swiss German, UK English, US English, and US English (Medical).

The user dictionary, user.upr, is your second, editable dictionary. You can create multiple user dictionaries, but only one can be used at a time. You can change user dictionaries at any time, or turn off the user dictionary entirely and use just the main dictionary.

To check spelling in the current field, record, found set, or layout:

1. Display the record or layout, find the set of records, or select the text to check.

2. Choose Edit menu > Spelling, then choose a spelling command.

3. If a questionable word appears in the Word box, choose an option.

Note  You can't change a word in a restricted or password-protected file or field. In that case, click Next.

 

To

Do this

Replace a misspelled word with one in the dictionary

Select a suggestion in the list and click Replace.

Revise a misspelled word that isn't in the spelling dictionaries

For Word, type your replacement. Click Check if you want the new word's spelling verified, or click Replace.

Leave the word as it is

Click Ignore All. Every occurrence of the word is skipped.

Leave the word as it is and add it to the user dictionary

Click Learn.

Note  You must have a user dictionary selected before you can edit it (see below).

4. When the spelling check is complete, click Done.

Note  You cannot check spelling in a web viewer, summary fields, or container fields.

To work with spelling dictionaries:

To create, select, and edit spelling dictionaries, choose Edit menu > Spelling > Select Dictionaries, then choose an option and click OK.

To edit, export, or import a user dictionary, choose Edit menu > Spelling > Edit User Dictionary, then choose an option and click OK.