Creating and managing layouts and reports > Working with popovers on layouts > Adding a popover
 

Adding a popover

You can add a popover to a layout to organize objects and make data entry easier. To add a popover to a layout, create a popover button. FileMaker Pro creates a popover at the same time. Add fields and other layout objects on the popover.

To add a popover to a layout:

1. In Layout mode, choose the layout you want from the Layout pop-up menu.

2. In the status toolbar:

Windows: Click the arrow next to the Button tool Button tool or the Popover Button tool Popover button tool, and choose Popover Button from the menu. Then drag the crosshair to draw the popover button.

macOS: Click and hold the Button tool Button tool or the Popover Button tool Popover button tool, and choose Popover Button from the menu. Then drag the crosshair to draw the popover button.

A popover button along with the popover are displayed on the layout.

3. In the Popover Button Setup dialog box, choose how you want the labels to appear.

By default, FileMaker Pro creates a label of text only, center aligned. See Defining or changing a button.

4. Choose additional options for the popover, including selecting the direction in which the popover opens, changing the popover’s title, and showing the title bar.

See Changing popover settings.

5. To assign one or more script triggers to the popover, click Set Script Triggers and choose one or more script triggers.

See Setting up script triggers and Automating tasks with scripts.

6. To add objects to the popover, select the popover. If the popover is not displayed, choose Format menu > Display Popover. To add objects, use the layout tools in the status toolbar, choose items from the Insert menu, or drag objects onto the popover.

7. Close the popover by clicking its close button.

Notes 

You can place a popover inside a portal; however, you cannot place a portal on a popover that’s in a portal.

Windows: Popovers cannot display in front of web viewers or interactive containers in Browse mode. To avoid overlapping these objects, a popover will shrink, if possible, or display behind these objects.

You can export data from fields on popovers with the following exceptions:

When you save or send data as Excel (using File menu > Save/Send Records as > Excel), fields on popovers are not included in the destination file. Use File menu > Export Records instead. After naming the destination file and setting Excel options, choose Current Table in the Specify Field Order for Export dialog box, then select the fields you want to export. See Exporting data from FileMaker Pro.

When you use the context menu in Table View to copy records or to save or send records as a PDF, fields on popovers are not included in the destination file.

When you use the Copy Record/Request script step or Copy All Records/Requests script step, fields on popovers are not included in the destination file.

If a script step specifies a field in a popover, the popover opens and the field is selected. If the same field appears elsewhere on the layout and the script finds that field first, the popover with that same field will not come forward. Instead, assign an object name to the field and use the Go to Object script step to move to that instance of the field.

Popover buttons are identified by a badge Popover badge in Layout mode. If you don’t see a badge, choose View menu  > Show > Popover Buttons.

Related topics 

Formatting buttons, popover buttons, and popovers

Setting auto-resize options for layout objects